Author Topic: 1977 White Bus Project "Cosmos"  (Read 338 times)

0 Members and 1 Guest are viewing this topic.

Offline kinggeorge13

  • Full Member
  • Posts: 158
  • Country: ca
  • Karma: 0
  • Bury me in my bus and put my tools in the back
1977 White Bus Project "Cosmos"
« on: November 28, 2016, 09:44:55 PM »
One of the sadder busses I have picked up, I bought this poor guy in the dark, in the pouring rain with only a test drive around the block on super-narrow Vancouver streets.  It's not like it's my first bus and not like I don't know better but I was walking away and the owner all but begged me to take it.   I got a deal but still probably paid too much and I knew this bus had problems.   The starter switch did not work and they had two bare wires hanging under the steering column you had to connect with a flash of sparks to get the starter to turn over and then disconnect them once it caught.  The windshield wipers did not work.   The PO swore they did work last time he used them (uh-huh....).   Third gear.........well, I did notice it did a little grind as I went into it the one time I went around the block and could get enough space to get speed up.   The dog legs?  One was rusted mostly away and the other.....well, it was completely gone: cut away by someone.  The roof on one side........had holes in it.  Actual holes.  Rusted holes where someone at one point tried to patch them with stickers that were no longer there.   The engine was not original and he said it had been rebuilt/replaced a few years back:  it now has two giant carburetors on it (not vintage 1977, that's for sure).  It backfired like crazy on decel.  The muffer.....well it may as well not have one, it sounded like a huge Harley as I accelerated.    The tail lights were wired wrong: on one side it flashed red for the signal and blazed orange for the brakes.  I didn't even finish my go-through because I was going to decline it.   But busses pull at my heart.   So we caved in and bought him.   The next evening, earlier with some daylight left and no rain, we went and did the paperwork and went to drive it home from deep in Vancouver (almost UBC) back to Fort Langley.   All we did was check there was oil and lights.   Off we went. 

What can I say?   But he's here and lots of problems (third gear is way worse than I even thought) and rust a-plenty but a good frame.   Some of the camping cabinets are missing.  A bunch of the electronics don't work, no interior lights work, not much works really.   But we've been working on it and rewiring and installing a very used Westfalia cupboard/sink that was so badly water damaged and rotten, I was not sure I'd get it fixed back up.   Replacing interior lights.  Fixing the leaks to stop the rain from further damage and at the same time prepping for next summers fun of doing a major overhaul on the body to repair/replace all the rusted areas and eventual repaint.   I'll have to take him in somewhere to get his 3rd gear fixed which is simply out of my league.    Everything else I believe we can fix ourselves.   

Meanwhile, Christmas is a month away and he needed some cheering up so yesterday's project was to get the 110v AC converter installed and give him some Christmas lights.   Oh yeah and a happy face wheel cover cuz his plain white one was rotted away and falling off.   

I think he's happier.  I took a picture.
Learning from my mistakes I'm clearly going to be a genius one day!

Offline Brenticon

  • Full Member
  • Posts: 51
  • Country: 00
  • Karma: -12
  • AirSpeed Forum Member
Re: 1977 White Bus Project "Cosmos"
« Reply #1 on: November 29, 2016, 09:25:45 AM »
:)

 

Powered by EzPortal